Page 19 of 51 FirstFirst ... 9141516171819202122232429 ... LastLast
Results 181 to 190 of 504

Thread: How to create a Cydia Repository

  1. #181
    Join Date
    Feb 2008
    Location
    18º24'N ~ 66º05'W
    Posts
    11,479
    Thanks
    503
    Thanked 1,251 Times in 854 Posts
    Downloads
    165
    Uploads
    738

    Default

    What is it that doesn't show correctly? I noticed that in your post your wrote "UUImages" for one of the folders when it should be "UIImages". That may be one of the problems. Can you zip a theme that is not working for you and send it to me? I'll take a look at it.

  2. #182
    Join Date
    Oct 2010
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Downloads
    1
    Uploads
    0

    Default

    I think I found something. The UUImages was a type-o in my post but it's correct in the theme.
    It has something to do with file permissions. I now have changed them to the proper ones and I'm trying to get it right this time.....

    Going once....going twice..... YES !!!

    So, I went wrong somewhere....I'm using Ubuntu in a virual box and my user was just a user. I made it an admin so I hope next time it will work right away.

    Or do you have other tips like chmodding the whole directory with all underlying files and folders ?

  3. #183
    Join Date
    Feb 2008
    Posts
    1,431
    Thanks
    16
    Thanked 164 Times in 132 Posts
    Downloads
    39
    Uploads
    9

    Default

    The iPhone4 has to be themed differently because of its resolution, you should be using the bundles method to theme the individual app icons as well as provide a high res image with @2x on the end, so icon@2x.png

  4. #184
    Join Date
    Oct 2010
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Downloads
    1
    Uploads
    0

    Default

    I know, I know, and that's what I'm doing

    I did something wrong somewhere, but when I went into the "Build" directory with Terminal, I used : "chmod -R 755 *" to get the theme to install properly.

  5. #185
    Join Date
    Feb 2008
    Location
    18º24'N ~ 66º05'W
    Posts
    11,479
    Thanks
    503
    Thanked 1,251 Times in 854 Posts
    Downloads
    165
    Uploads
    738

    Default

    I can't tell you much about using a virtual setup but I know that your permissions will not be correct if you are not running as the administrator. Make sure the theme folder's permissions are correct before building the .deb otherwise everyone will have to use Terminal to fix them. Also, you can also upload the themes to your iPhone and build the .debs there. That's the method I mostly use.

  6. #186
    Join Date
    Oct 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Downloads
    0
    Uploads
    0

    Default

    Thanks for your detailed guide. After follow your steps by steps, the cydia works, but when I run the app, it just flash the screen and finish, nothing happen. Do you know the reason? My host's at: http://222.252.16.106/iphone/

    Thanks alot!

  7. #187
    Join Date
    Oct 2010
    Location
    Bhubaneswar,Odisha,India
    Posts
    27
    Thanks
    10
    Thanked 0 Times in 0 Posts
    Downloads
    2
    Uploads
    0

    Default

    Thank You guyz....

    This things are very very helpful..

  8. #188
    Join Date
    Oct 2010
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Downloads
    0
    Uploads
    0

    Default

    Ok, I have a question maXimus. I set up my own repo and I made some ringtones and put them in there and they work fine. The problem I am having is when I add free apps they don't seem to show up in the list although they are in the Packages files. Any idea on this one?

  9. #189
    Join Date
    Feb 2008
    Location
    18º24'N ~ 66º05'W
    Posts
    11,479
    Thanks
    503
    Thanked 1,251 Times in 854 Posts
    Downloads
    165
    Uploads
    738

    Default

    Are you hosting free apps that were already in Cydia? If so, you won't see them if you are using the same bundle identifier in your control file since they are already in Cydia. If that's the case, then you need to change the bundle identifier to something different.

  10. #190
    Join Date
    Oct 2010
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Downloads
    0
    Uploads
    0

    Default

    Ok I will have to look at that, ty sir.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •