• How to fix "Unable to Load" and "login" error in new FaceBook app version 3.2

    Ok so many of us have updated our Facebook app last night so we can get the new and buzz worthy feature of FB locations. (or whatever is called). In any case as soon as I updated mine I realized that I can no longer use the app as I was getting "unable to load" content error message on pretty much every screen of the app. I tried login off and login back in, but then I got "unable to login please try later" message. I tried deleting and re-installing the app but that didn't work. I looked at some comments in the app store and realized that many people are having the same issues but not all, so I knew it was some app conflict issue or what not.

    Anyway after spending an hour going all over the net this morning I finally found the solution. I can't find the link any more, but I'll try to sum up what needs to get done to get it working again.



    1.Launch SBSettings
    2.Tap on More
    3.Mobile Substrate Addons
    4.Scroll down until you see "biteSMSsb" and turn it off
    5.Exit SBSettings (your phone will respring as always)

    Your Facebook app should work now and you can use the new location feature.

    You should be all good to go, right?! Wrong. Yes FB works now, but quick compose and quick reply are no longer working in your bitesms (in my case). To me that is the whole point of that app. So since I use bitesms more then FB app I decided to switch everything back and just use the mobile version of Facebook.

    In any case, other Cydia apps might be having this same conflict and I hope FB app people realize that this is impacting millions of jailbroken users and they fix the conflict. Comment if you are effected by this with a different Cydia app.
    This article was originally published in forum thread: How to fix "Unable to Load" and "login" error in new FaceBook app version 3.2 started by omakad View original post
    Comments 3 Comments
    1. omakad's Avatar
      omakad -
      Well as of this morning Internet is buzzing with this problem and solutions. I have found this fix on few places but I have not tested it myself yet.

      Edit the file /Library/MobileSubstrate/DynamicLibraries/biteSMSsb.plist to only contain:
      Filter = { Bundles = (com.apple.springboard); };

      Also biteSMS has posted on their forums that cydia packaged fix is coming out on Monday so if you don't feel comfortable SSHing into your phone just wait few days for the update.

      Also some people suggested to downgrade your FB though Instalous if that's your cup of tea.
    1. maXimus's Avatar
      maXimus -
      Don't you love being an early adopter?
    1. omakad's Avatar
      omakad -
      Facebook just released version 3.2.2 which fixes these issues. FYI