• Apple will patch the JailbreakMe PDF Exploit with the new iOS upgrade





    Yes, the Spokewoman from Apple confirmed to CNET that they already have a patch for the new exploit from the DevTeam.

    She said:
    We’re aware of this reported issue, we have already developed a fix and it will be available to customers in an upcoming software update. There are two distinct vulnerabilities in the iPhone uncovered with the jailbreak software’s release, One flaw is in the way the browser parses PDF files, enabling the code to get inside a protective sandbox, and the other hole allows code to break out of the sandbox and get root, or control, privileges on the device.
    That means if you haven't gotten your new iPhone 4, hurry before Apple patches it!!

    Via CNET
    This article was originally published in forum thread: Apple will patch the JailbreakMe PDF Exploit with the new iOS upgrade started by nsandymary View original post
    Comments 3 Comments
    1. overjjrk's Avatar
      overjjrk -
      and the other hole allows code to break out of the sandbox and get root, or control, privileges on the device.
      Now that we are post jailbreak legalization, this statement seems rather funny. Come to think of it, its even funnier because she ends by saying "device". Hasn't Apple always contested that we own our device, but not the OS.
    1. maXimus's Avatar
      maXimus -
      Good point overjjrk!

      I hope jailbreakers are smart enough to know not to update when the release comes out. But we knew it was coming. Userland jailbreaks are so easy patch.
    1. Kruejl's Avatar
      Kruejl -
      Yep, it was only a matter of time for Apple to close the hole.