PDA

View Full Version : "different sim detected" unlock error after Quickpwn to 2.1 "FIX"



djdownhill
09-25-2008, 09:25 AM
I found this on ModMyi and I can tell you this worked for unlocking my iPhone.

Special thanks to peking for the find!

Here is an additional download of the Lockdown file from my 4shared account as well:

http://www.4shared.com/file/64411599/d3426224/unlocked_21_Lockdown_file.html


Hey Guys,
im having trouble with my phone after the latest update to the 2.1 FW.
I have always been using the Pwnage tool to JB/unlock my phone since the 2.0 upgrade.

After trying to update to 2.1 using Pwnage i was getting a "error 2001" in itunes 8. The phone was jailbroken/unlockd before this with 2.0.2. At this point i decided to just use quickpwn OS X as my phone was already unlocked from 2.0.2. This worked fine.

Problem is now when i put my Aussie sim card in its giving me "different sim detected" error and telling me to connect to itunes. Im getting a signal in the signal bar at top and am assuming i would be able to receive calls etc but cant get past that activation screen.

When i put the original sim in im able to access the phone. I put Bootneuter on the phone via cydia with original sim installed just to try unlock just in case somethings wrong here but bootneuter tells me "nothing to do-your choices already match current setting, so theres no need to flash".

So im stuck at the "different sim detected" screen with an ulocked JB phone. Ive been looking all over the net for a solution and have noticed a couple of people with the same problem and no answers. Anyone with same problem and more importantly anybody with any solutions?

HELP!! :confused: :(

UPDATE: i forgot to add this is a 2G phone that was recently replaced and activated by Apple...i took it home and JB/unlocked it at 2.0.1 but had never used my Aussie sim card to test if the unlock worked at that point as i was using the ATT here in the States. Ive been reading that i may need a patched lockdown file but that was in some earlier posts for FW 1.x.x

OK heres the solution that just worked for me:

download patched lockdownd file from here:


RapidShare: Easy Filehosting (http://rs309.rapidshare.com/files/139572019/Lockdown.zip)

SSH into phone using cyberduck/WinSCP

1. navigate to to /private/var/root/Library/ and copy lockdown folder to your desktop (for backup just in case

2. delete that folder from phone

3. unzip downloaded patched file and upload to phone to replace the folder you just deleted

4. naviagte into patched folder and make sure file pemissions are set to 644 for all files

5. reboot phone...

that worked for me!!!! :)

chuckturner
09-25-2008, 11:58 AM
Thanks DJ:thumbup:

maXimus
09-25-2008, 12:23 PM
I had this problem and I can tell you a much easier solution: restore to 2.1 and run quickpwn with a non-official SIM. That's it!

QuickPwn senses the legit activation and doesn't hack the activation, therefore, you can't put in another SIM afterwards even if BootNeuter is telling you that you're neutered. Notice that he said this:


When i put the original sim in im able to access the phone. I put Bootneuter on the phone via cydia with original sim installed just to try unlock just in case somethings wrong here but bootneuter tells me "nothing to do-your choices already match current setting, so theres no need to flash".

That's the same thing that happened to me. The whole problem is pwning it after the "official" activation. That causes the problem. No need for the fix. Just put in a different SIM, restore to 2.1 and run quickpwn. I did this 8 times to 2 different phones to prove this. Maybe I should post it at MMi!! :cool:

BTW, I am sure the method that peaking posted works. And it's a great fix if you've already done everything. But the best thing would be to restore and pwn with a non-activated SIM to start with and you shouldn't have the problem! :cheers:

djdownhill
09-26-2008, 01:38 AM
...........................
Hey............:D

Don't thread crap my crappy thread........:bigcry::banging::bigcry:


J/K.......


Yeah I was to lazy to flash my phone again so I WUSSED out and just deleted/added the file.....:lol:

maXimus
09-26-2008, 09:22 AM
Don't thread crap my crappy thread........:bigcry::banging::bigcry:
Sorry!!!!!!! It was unintentional!!! :laugh:

Just wanted to give an explanation and alternative!!! You're still the man!!! :thumbup:

MrBucket101
09-26-2008, 11:34 AM
Hey............:D

Don't thread crap my crappy thread........:bigcry::banging::bigcry:


http://i164.photobucket.com/albums/u2/rabbidturtleracing/poop-1.jpg


uh oh...

maXimus
09-26-2008, 12:49 PM
http://gleesongleanings.files.wordpress.com/2008/06/grusskarte_sorry.jpg

:lol: :D :laugh:

djdownhill
09-26-2008, 06:26 PM
Blah....

No worries maX. :lol: